SQL SERVER – Understanding JSON NULL Value Using STRICT Keyword
Playing around with the new capability of SQL Server 2016 has been a fun journey. Even after a year, the discovery keeps happening every single day that I work with it. When I wrote the post around...
View ArticleSQL SERVER – Script level upgrade for database master failed – Error: 4860,...
Of late, I have been contacted by few clients who have been facing issues with SQL startup failure after applying patch to SQL Server instance. This blog is an outcome of one such assistance provided....
View ArticleSQL SERVER – SQL Installation fails with error code 0x851A001A – Wait on the...
One of my client was trying to deploy his product on their test servers. They found that the SQL Server installation was failing with below error. Let us learn about error Wait on the Database Engine...
View ArticleSQL SERVER – Using dm_db_stats_properties With InMemory OLTP Tables
The whole concept of InMemory OLTP has been around for a while and still there are areas that I try to go back to learn every single time. If you are new to InMemory OLTP, I would highly recommend...
View ArticleJoin Me at SQL Konferenz 2017
I will be presenting at SQL Konferenz in Darmstadt, Germany next month. If you are in, or near, Darmstadt in February I hope you take the time to join us at SQL Konferenz!The post Join Me at SQL...
View ArticleSQL Server – When to Use a Sledgehammer and When to use a Screwdriver
Some organizations use SQL Server Always On Availability Groups to help boost performance of applications where the users are geographically dispersed. They accomplish this by placing the secondary...
View ArticleSQL SERVER – Script level upgrade for database ‘master’ failed – There is...
SQL Server troubleshooting topics seem to be the most searched for in this blog. In continuation to this, blog for today is also inspired with one such error message. Some time back I have written...
View ArticleSQL SERVER – Understanding JSON Use is Case-Sensitive
The things I get to learn from my daughter is amazing. I think all of us need to constantly explore without any prejudice and set biases. Whenever I get a new toy for some occasion, I see there is at...
View ArticleSQL SERVER – AlwaysOn AG (Availability Group) and TDE Error – Please Create a...
Along with performance consulting, sometimes I also get requests from a few clients to look at the AlwaysOn availability group related problems.ENVIORNMENT:Three node AlwaysOn availability group with...
View ArticleSQL SERVER – Unable to Apply Security Patch – The setup has encountered an...
One of my clients reported that he is trying to apply security patch for SQL Server clustered instance and it was failing. Since this is SQL 2005 instance, there is no official support available from...
View ArticleSQL SERVER – Fix – Error 15240, Severity: 16, State: 2 – Cannot write into file
I always keep playing with my virtual machine which has SQL Server installed. Recently I was trying to apply the patch of SQL Server and I was surprised to see that SQL Server was not getting started...
View ArticleSQL SERVER – The Log Scan Number Passed to Log Scan in Database ‘master’ is...
If you have landed on this blog by searching below error, then I must tell you that your SQL Server service is not getting started. Let us learn in this blog how to fix The Log Scan Number Passed to...
View ArticleSQL SERVER – Why Cluster Network is Unavailable in Failover Cluster Manager?
It’s always a good experience to visit customer sites and talk to people. Sometimes I get to see things outside SQL world as well. There is a lot to learn and I believe that I can do that by sharing...
View ArticleSQL SERVER – Query to Get the List of Logins Having System Admin (sysadmin)...
Though the script sounded simple to me, but I found that there are lots of incorrect scripts available on the internet. Here is the one of the script I found to find out the details of the system...
View ArticleSQL SERVER – How to get historical deadlock Information from System Health...
Let me start off by asking a simple question. How many of you have seen this error about historical deadlock information earlier?Msg 1205, Level 13, State 45, Line 4 Transaction (Process ID 52) was...
View ArticleSQL SERVER – Unable to Start SQL Service – Server TCP provider failed to...
While playing with my multiple SQL instances, I realized that I was not able to start one of the SQL instance on my laptop. Here is the error which I received when I tried starting it from Start >...
View ArticleSQL SERVER – Database Mirroring Login Attempt Failed with Error ‘Connection...
One of my friends was trying to configure database mirroring and was having a hard time in getting things working. The challenge was that he was using certificate for mirroring authentication because...
View ArticleSQL SERVER – SSMS – Script Out Multiple Objects
Have you ever driven your car out in the direction of your office by mistake when it was supposed to be a day off? Have you ever done things unconsciously because you are getting trained for something...
View ArticleSQL SERVER – Installation Error – [Microsoft][ODBC Driver Manager] Data...
One of my blog readers sent an email to me asking for assistance. They were trying to patch SQL Server 2005 in the cluster and the setup was failing to patch database services with below error related...
View ArticleSQL SERVER – Fix Error Msg 13603 working with JSON documents
Working with new data types is something we need to evolve. In this blog, I have written on a number of articles on JSON which you can take a look at. I wanted to write about some of the interesting...
View Article